Scheduled for March 13, 2026 at 7:30 AM – 7:45 AM
Affects
Admin Panel
Under maintenance from 7:30 AM to 7:45 AM
Checkmk Sites hosted in the EU
Under maintenance from 7:30 AM to 7:45 AM
Checkmk Sites hosted in the US
Under maintenance from 7:30 AM to 7:45 AM
Completed
March 13, 2026 at 7:45 AMCompleted
March 13, 2026 at 7:45 AMMaintenance has completed successfully
In progress
March 13, 2026 at 7:30 AMIn progress
March 13, 2026 at 7:30 AMMaintenance is now in progress
Planned
March 13, 2026 at 7:30 AMPlanned
March 13, 2026 at 7:30 AMWe will be conducting scheduled system maintenance tomorrow, Mar 12, 2026, from 08:30 to 08:45 CET to enhance system performance, reliability, and security of Checkmk Cloud.
Details:
Maintenance Window: 15 minutes
Expected Downtime for Client Sites: Minimal (less than 5 minutes)
Impact: During the downtime you will not be able to reach your site, nor will the site be able to receive metrics/connections from Checkmk agents. We appreciate your understanding and cooperation as we work to improve your experience. Should you encounter any issues after the maintenance period, please contact our support team through the Support Portal.